Project Treble LePro3 X720/X722/X727 No Mediatek Support

Project Treble Lepro3. Yes now you can flash and RUN the whole GSI by Phhusson, let’s see together what kind of requirements needed.

Project Treble LePro3

Requirements:

  • 20S or newer.
  • Unlocked Bootloader.
  • Special TWRP that contain the support fot /vendor partition.

How was possible?

  • Thanks to the port on LeMax2, click here.

How I port it?

  1. Applying patch to mount /vendor .
  2. Port TWRP from LeMax2 and replace it kernel from ZL1 with the whole patch.

Can I Flash Android P DP5?

  • Yes but how?
  • Make sure to have my LineageOS 15.1.
  • Download Android P DP5 and 1-2-3 packages.

for more information, click here to read my own thread on xda-developers.

Project Treble LePro3 X720/X722/X727 No Mediatek Support